Logitech: Spark Requirements & Supported Devices

To ensure that Logitech: Spark works as intended, the following software & one of the Logitech RGB supported keyboards listed below are required.

Requirements:

  1. Logitech Gaming Software (LGS) installed & up to date
  2. Overwolf installed & up to date
  3. Logitech: Spark (Overwolf app) installed

Supported Keyboards:

Unsupported devices:

**Note: G213 does not support RGB Lightning Per-Key. (RGB Lightning Per-Key means that each individual keyboard key can be illuminated with a different color which is essential to the Logitech: Spark app).

Was this article helpful?

Related Articles