Overwolf crashing \ Not starting .NET 4.5 issue

It seems that some operating systems may have a corrupted .NET version installed on them. Overwolf is based on .NET 4.5 and will fail to run on these operating systems.
This scenario can happen due to an update for your OS, like updating it from Windows 7/8/8.1 to Windows 10 or even outdated drivers.
We found that the best solution as for now is reinstalling your .NET 4.5, this is how you do it:

  1. Press on the windows key + R
  2. Type in: appwiz.cpl
  3. Click on "Turn Windows features on or off"
  4. Look for the ".NET Framework 4.5\4.6" and uncheck it
  5. Click OK and wait
  6. Once it is done close it and restart your computer
  7. Follow steps 1-4 in order to re-check the ".NET Framework 4.5\4.6" option
  8. Restart your computer
  9. Try running Overwolf

If you still need any further assistance, please contact our support team at support@overwolf.com

Was this article helpful?

Related Articles